Thread Closed
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Install of kplaylist failing

cPanel: cht

Detailed description: Attempts at installing kplaylist using Softaculous results in the sub-domain giving a HTTP Error 500. I would like to know what the issue is.
Looks like a permissions issue - will let un4 know.
(07-12-2017, 08:52 AM)Genesis Wrote: Looks like a permissions issue - will let @un4saken know.

set files to 0755 (-rwxr-xr-x).

or it can be a coding Error in .htaccess file
@CHT We're still waiting for un4 response, however if I may ask, have you tried to install the script outside Softaculous, like upload the script to your cpanel and install it yourself? I'm just trying to see whether the permissions issue is on the Softaculous side - probably is.
Tried, same issue.
OK in absence of un4 while he is away I Googled kPlaylist:

What I noticed was that all of the documentation is still 2008. Like it may be an old patched script. The script download in the Website is dated 2015 but everything else including the Changelog is still 2008.

1. For that reason can you check whether the versions downloads that you have are the last updated version of kPlaylist (2015).

2. For the same reason can you check the version of php in your cpanel. Like maybe if you set it to an earlier version php that may work.

This is what it recommends in the Release Notes but probably for the 2008 version but for that reason looks as though the script may work better with an older version of php.
OK, further to above just checked my own cpanel and looks as though un4 only has two versions available of php. 5.6 and 7.0. I then went ahead and installed the script with Softaculous and got the same error as you.

I then went into File Manager and checked the error log that came up with:

Quote:[13-Jul-2017 08:27:44 UTC] PHP Fatal error: Cannot re-assign auto-global variable _POST in /home/name/public_html/kplay/index.php on line 9549

I then Googled that error, and indeed this has to do with the version of php. So it's really an issue with the script that it is still on an older version of php - from what it looks like it even predates version 5.4. I then Googled the error message and in that you can look yourself as perhaps you'll be able to modify it so that it will work for you. I'm running out of time now as spent more time on it than I really have, but maybe you could try too. Here is a whole list of links to explore for how to fix the issue.
Somehow, Softaculous is using the "stable" release dated for the year 2008 instead. After trying the 2015 build, the site is up.

Issue solved, thanks @Genesis.
Glad to hear CHT. Good

- closed -

Users browsing this thread:
1 Guest(s)

Install of kplaylist failing568