Thread Closed
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lets Encrypt not working
#1
[Solved]
So I tried removing the SSL cert for my domain and readding it as my SSL shows as an insecure connection when I check the cert details I see this

The certificate is only valid for the following names: azmechanic.com, mail.azmechanic.com, http://www.azmechanic.comDetails
The hostname in the website’s security certificate differs from the website you are trying to visit.Error Code: DLG_FLAGS_SEC_CERT_CN_INVALID

yet under my check SSL it shows  techiemike.com AutoSSL Domain ValidatedExpires on February 11, 2018. The certificate will renew via AutoSSL.      mail.techiemike.com AutoSSL Domain ValidatedExpires on February 11, 2018. The certificate will renew via AutoSSL.      http://www.techiemike.com AutoSSL Domain ValidatedExpires on February 11, 2018. The certificate will renew via AutoSSL when the parent domain “techiemike.com” renews.

I have tried different browsers etc cleared cache still same problem?
 
please advise
#2
[Solved]
Are you connecting to your site using direct URL https://azmechanic.com ? I mean your are not using ip or any proxy in your URL.
I tested connection and found it ok.
Your certificate signed by AddTrust AB which is trusted in my chrome. Is it set as trusted in your browser?
#3
[Solved]
Oh I see. The issue is in https://www.techiemike.com connection
I can't understand, why are you using certificate generated for  azmechanic.com if your domain is techiemike.com?
#4
[Solved]
I switched all accounts to Comodo SSL and disabled Let's Encrypt. Your website should work with ssl soon.
Please do not email or PM me with private support requests - Use Support Section.
Don't forget to read TOS.
Never argue with idiots.
First, they'll bring you down to their level and then beat you with their experience!
[-] The following 1 user Likes un4saken's post:
  • Genesis
#5
[Solved]
(11-13-2017, 03:38 PM)un4saken Wrote: I switched all accounts to Comodo SSL and disabled Let's Encrypt. Your website should work with ssl soon.

Great job Un4saken! One question, are SSL/TLS certificates still free with Comodo SSL? All my current sites' certificates look like they moved over fine, but if I wanted to add a new domain in the future all the options to add a new certificate look like they cost money now...
resim
resim
#6
[Solved]
Thank you this domain is the one that was generated by letsencrypt " https://azmechanic.com " even though I had chosen my own domain techiemike.com it is still showing as insecure and using the azmechanic.com domain despite my control panel showing a valid cert. I will test again after work

thanks

Mike
#7
[Solved]
So I am still getting the insecure connection as the cert is for " https://azmechanic.com "  ?please advise 

thanks

Mike
#8
[Solved]
@Yozora You don't need to add SSL certificate manually when you add a new domain, certs will be added automatically and it's free.
@TechieMike i've changed some settings, please wait for the next cPanel cron job run, like 12 hours or so.
Please do not email or PM me with private support requests - Use Support Section.
Don't forget to read TOS.
Never argue with idiots.
First, they'll bring you down to their level and then beat you with their experience!
#9
[Solved]
@un4saken Oh, got it! Thanks! That's really convenient. Smile
resim
resim
#10
[Solved]
Ok so even after installing my own paid cert it is still not working and its tring to use this website cert instead

simpegprg.riddict.gigapages.net, http://www.simpegprg.riddict.gigapages.net 

please advise as this is breaking my website security, oh and toy have removed access to SSL from cpanel?

thanks Mike
  




Users browsing this thread:
1 Guest(s)

Lets Encrypt not working485