Thread Closed
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Wordpress permission problem

Hi, I have very weird technical difficulty with the WordPress site I am hosting, I have asked Genesis to redo my account, but the problem still persists and its very annoying and stops me from running two websites.

cpanel name: emnowiny

The freshly uploaded images are not showing up as seen on the screenshot

And there is error in developer console.
Quote:Failed to load resource: the server responded with a status of 404 ()

I have tried all solutions from the internet and none of them worked.
[Image: userbar.png]
[Image: polandbar4.gif]

To figure out a solution to the problem by @un4saken can you also let him know the steps you followed:

(a) how did you originally upload those images to your WordPress site?
(b) when you reinstalled the WordPress site - how did you reinstall it? Did you start a fresh installation and import the database? Did you import the images as well? As the database and images work separate from one another. In the days when I was still using this method I noticed my images were not uploaded with the database. You have to figure out where they are and then add the images to the images folder.

If I may offer a solution for future fault free option for migration of WordPress sites - I use the WP Plugin All-in-one WP migration tool.. It's effortless to use. it's a plugin with which you download a full backup just with two clicks of your button from the plugin in your WP Dashboard to the hard disk of your computer. Then at the destination server you just install wordpress and add the plugin. Then upload the backup from the hard disk of your computer. Don't forget after the installation then to save the permalinks twice. Then everything appears exactly as it was when you made the backup including version of WordPress, images, etc.

I did some research with Google, since I've got a great interest in WordPress these seem to be possibilities for the images problem too.

1. If you uploaded the images through FileZilla the transfer mode of the images needs to be set to ASCII:
[Image: wordpress-images-not-showing.png]

2. If you upload the WP database and images with the WordPress Importer you need to select "import images" option. Apparently some people forget to do that. The images were not imported automatically in the wp_posts database - you need to tell it to do so. They are stored in there as an "attachment" post type. The WP Gallery Shortcode references the id of each of those entries to build the gallery. Your media library also displays the images based upon the database. Wordpress doesn't just detect images in the uploads folder.

3. Also note that this could be theme related when Websites are moved or migrated. The issue can be caused by peculiarities of certain themes and doesn’t always occur. The only reason is to upload the needed files again and insert them anew.

4. If the above possibilities are not the case, it could also be the media folder path is set incorrectly - not sure why - but when I researched it that seems to be a possibility as well. You can fix it in the WP configuration file by setting it to wp-content/uploads.
[Image: featured-image-not-showing.png]

5. Another possibility - when you upload your images through WordPress do you do it correctly through the media library? Like click on the media tool for uploading it, then clearly saving it in your media library. Like dragging and dropping or the easy ways aren't good apparently for when you want the images included when you migrate or reinstall the site.

As I said in my op, I tried everything, but nothing works. I did spend 2 nights hopeless trying to solve the problem and on every occasion and every source to fix it, it said if the problem still persists contact your web hosting.

I have tried to use the script installer as well as the manual install of wordpress. I even tried to downgrade the wordpress core to the previous versions, nothing has fixed it.

I have tried permissions, adding media paths to the wp-config, every possible way I ended up with the same outcome, It didn't work.

It didn't even let me to import images via wordpress importer due to permission error.

I did set very high values for max upload and post in my php.ini.

Like I said, I have tried everything and all it came up with the same permission error, cause you have to have either 755 or 750 on upload folder, but when I do that, I can't upload anything on the site.

After installing the plugin I got this:
[Image: vMaPJWt.png]
[Image: userbar.png]
[Image: polandbar4.gif]
Thanks @GigaGreg. You still haven't answered the question though. How did you upload the images when you uploaded them the first time? Like did they come with the theme, or did you use the Media tool to upload the images from your hard disk? Do you know the exact path to the images BEFORE the backup was made?

Like the message I got in the support forums is that problems that occur may have something to do with how the images were uploaded the first time when you used them. Like when backups are made they usually look for the images in fixed places. Maybe it missed the images, or the images are in a different folder than what the import tool is looking for.
I told you in my three previous posts, I tried everything to make it work, but nothing works. I tried to upload via ftp, via media tool, drag and drop, using the normal file upload, nothing works.
[Image: userbar.png]
[Image: polandbar4.gif]
(09-23-2018, 04:26 PM)GigaGreg Wrote: I told you in my three previous posts, I tried everything to make it work, but nothing works. I tried to upload via ftp, via media tool, drag and drop, using the normal file upload, nothing works.

That is correct. You told me what you did with the images AFTER you reinstalled WordPress BUT you didn't tell me how you uploaded the images BEFORE reinstallation, that is during the first and original installation when the images were uploaded the first time.

One of the most common problems (it happened to me too a few years back) is that the images are in a different folder than the folder the new WordPress installation is working with. You can check the tech article below:

WordPress automatically takes its images from the uploads folder and in a specific order - you need to check where the images you are missing are located in the uploads folder and then move them to the sub-folder that the new installation of WordPress is working with.

If you haven't checked it before, go to the wp-content folder, then click on uploads, and then look for your missing images. Then check where the new images are located.

If you want either me or Misharnet to help let us know. I really feel your frustration and hope it can be sorted out.
I've just checked my WordPress @un4saken. @GigaGreg is right. We have a WP permissions problem. I've just tried to update my plugins and I was unable to do so as we don't have author permission to do so on our WordPress sites. We are also unable to change the privileges of folders to 777 as there is something in the system that keeps on resetting it back to what it was before. We don't seem to have privileges to change folder privileges.

If I had a VPS I'd have been able to fix it with:

chown admin -R *

Not sure what is happening with our system though. Like maybe a security plugin that is creating a problem for our author and folder privileges.
[-] The following 1 user Likes Genesis's post:
  • GigaGreg
As always, Un4saken did his magic, even image upload is fixed.
[Image: userbar.png]
[Image: polandbar4.gif]
[-] The following 3 users Like GigaGreg's post:
  • Genesis, un4saken, Yozora
(09-24-2018, 11:54 AM)GigaGreg Wrote: As always, Un4saken did his magic, even image upload is fixed.

Absolutely. Am really happy everything has been fixed.

Thanks @un4saken Drinks Drinks Drinks Drinks

Users browsing this thread:
1 Guest(s)

Wordpress permission problem46