Jump to the post that solved this thread.
  Thread Closed
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Problem with WP Plugin. (Shared Hosting)

#1
[Solved]
I made a topic in Wordpress board about White Death problem but it seems the whole thing is beyond just updating plugins. Now if I activate Jetpack or Yoast SEO then site goes blank. I have 2 Wordpress sites there and same thing happen on all 3 of them.

I haven't had time to looking into this since last year but all the problems started after moving to new server.  So I wonder if it's something to do with memory limits ?
Software and cathedrals are much the same – first we build them, then we pray
#2
[Solved]
https://codex.wordpress.org/WP_DEBUG

Put these lines to your wp-config.php file to find the issue.
PHP Code:
define'WP_DEBUG'true );
define'WP_DEBUG_DISPLAY'true );  
Please do not email or PM me with private support requests - Use Support Section.
Don't forget to read TOS.
Never argue with idiots.
First, they'll bring you down to their level and then beat you with their experience!
#3
[Solved]
Quote:Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 12288 bytes) in /home/xdude/public_html/wp-content/plugins/wordpress-seo/inc/sitemaps/class-taxonomy-sitemap-provider.php on line 76
Quote:Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 3200 bytes) in /home/xdude/public_html/website.com/wp-admin/includes/template.php on line 441

Different error locations but the same error on both sites. Looks like the same old memory exhausted problem.
Software and cathedrals are much the same – first we build them, then we pray
#4
[Solved]
Which version of Jetpack did you use @xdude? I checked WordPress and someone with the same problem got it solved by using a more recent version of the plugin. This one seems to be the most up to date one - is this the one you're using?
https://jetpack.com/2018/08/07/jetpack-6-4-release/
Source of discussion: https://wordpress.org/support/topic/jetp...te-screen/

With Yoast - maybe @un4saken could help:
Quote:Problem Resolution
This issue is caused by a missing dependency. Yoast SEO now requires the php-bcmath library.

If you're on a shared server, you'll probably need to ask your hosting provider to install the missing library. If you're on your own virtual server or a dedicated machine you can fix the issue by installing the php-bcmath library. For example on CentOS servers you would run:
PHP Code:
yum install php-bcmath 
Source: https://clients.websavers.ca/whmcs/knowl...creen.html

Another person solved the problem with removing a javascript optimizer plugin:
Quote:Hi, I solved my problem. I deactivate the plugin Async Javascript Optimizer and now it’s working Yoast Seo!!
So people then started to think it may have to do with javascript conflicts.
Quote:berndtl’s comment makes sense as Yoast SEO runs fine on a website I am developing that doesn’t have any javascript defer loading mechanisms in place right now. The SEO layout on the page even looks different.
Source: https://wordpress.org/support/topic/blan...er-update/

#5
[Solved]
Well I have the latest Jetpack version. I found the White Death when i checked it for first time and then i upgraded all plugins. Blog started working and I activated all plugins one by  one. Once I tried to activate Jetpack it's gone all white. Other site didn't have Jetpack activated but there White Death came when I tried to activate Yoast SEO.

I dont have java script plugins in either of the sites.
Software and cathedrals are much the same – first we build them, then we pray
#6
[Solved]
Go to MultiPHP INI Editor in your cPanel. Select your domain, change "memory_limit" to 256M and click apply. This will solve your problem.
Please do not email or PM me with private support requests - Use Support Section.
Don't forget to read TOS.
Never argue with idiots.
First, they'll bring you down to their level and then beat you with their experience!
[-] The following 1 user Likes un4saken's post:
  • Genesis
#7
[Solved]
Thanks @un4saken

From there I did upgrade the PHP version to 7 and it seems worked too. Now all problems are gone and all 3 sites work perfectly. Maybe when PHP version upgrades memory limit also increases ? or it might be something else which got sorted in newer version of PHP. Anyway I'm glad it's all sorted out and sites working like those should be.
Software and cathedrals are much the same – first we build them, then we pray
[-] The following 1 user Likes xdude's post:
  • Genesis
#8
[Solved]
Necro posts removed.

Discussion was completed a long time ago.

- closed -

  
Jump to the post that solved this thread.




Users browsing this thread:
1 Guest(s)

Problem with WP Plugin. (Shared Hosting)551