Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

SSL default/redirect

#1
[Not Solved]
Hi,
I've got ssl working on my site, but if I just type the url, mysite.gigapages.net, it goes to the non-https site. I have to prefix it with https:// to get to the secure site. I've scoured through cpanel without getting any clues... How do I get it to default to the https:// site?
Peter
#2
[Not Solved]
(01-11-2020, 07:34 AM)1peter1 Wrote: Hi,
I've got ssl working on my site, but if I just type the url, mysite.gigapages.net, it goes to the non-https site. I have to prefix it with https:// to get to the secure site. I've scoured through cpanel without getting any clues... How do I get it to default to the https:// site?
Peter

Did you have a Website on it before you had ssl working on your site? Have you deleted all the cookies and cache on your computer?

What kind of site is it? Do you have a WordPress site or any other site that works through a database? If yes, you need to change the domain in your database by going into DirectAdmin to make the change in the database as well as go into the Dashboard of the WordPress site and check the permalinks. You may need to change the URL in the permalinks as well. Remember to save it twice when you've made changes and then to get rid of all of the cookies and cache before you check the changes. It may also take some time for the changes to propagate.

#3
[Not Solved]
(01-11-2020, 07:34 AM)1peter1 Wrote: Hi,
I've got ssl working on my site, but if I just type the url, mysite.gigapages.net, it goes to the non-https site. I have to prefix it with https:// to get to the secure site. I've scoured through cpanel without getting any clues... How do I get it to default to the https:// site?
Peter
You can create a redirect from http to https in the "Domains" section, but if you have already done so, Genesis tips may help you.
[Image: 86VOeKA.png]
[Image: NZSllY1.png]
#4
[Not Solved]
Not sure if you are familiar with .htaccess files but this is what I use:
Code:
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
#5
[Not Solved]
I am using following code under .htaccess file for the redirection and seems to be working fine for me.
 
Code:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
</IfModule>

Only thing I needed to do is log into the cPanel, head to the file manager, navigate to domain root directory and edit the .htaccess file to copy paste that above piece of code.

Its now redirecting all traffic on my domain to https !!

(By the way, by default the .htaccess file is hidden, so under file manager, just turn on hidden file display to show .htaccess under domain's root directory)

Thanks.
#6
[Not Solved]
(02-19-2020, 06:26 PM)hunky Wrote: I am using following code under .htaccess file for the redirection and seems to be working fine for me.
 
Code:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
</IfModule>

Only thing I needed to do is log into the cPanel, head to the file manager, navigate to domain root directory and edit the .htaccess file to copy paste that above piece of code.

Its now redirecting all traffic on my domain to https !!

(By the way, by default the .htaccess file is hidden, so under file manager, just turn on hidden file display to show .htaccess under domain's root directory)

Thanks. 

Why waste time on .htaccess if you can already do this with one button in cPanel?
[Image: NZSllY1.png]
#7
[Not Solved]
you can install Really Simple ssl plugin if you are using wordpress.
#8
[Not Solved]
If you activated the one click force SSL on cPanel, it will work.
Also try to test your website on different browser of in incognito mode.
#9
[Not Solved]
also, there is a way to make sure the website won't be served unsecured from cache with https://developer.mozilla.org/en-US/docs...e-Requests
  




Users browsing this thread:
3 Guest(s)

SSL default/redirect589