After deleting a binary file from Git history why is my repository still large?

admin

Administrator
Staff member
So let me preface this question by saying that I am aware of the previous questions pertaining to subject on Stackoverflow. In fact I've tried all the solutions I could find but there is a binary file in my repo that just refuses to be removed and continues to greatly inflate my repo size.

Methods I've tried,

<ul>
<li><a href="http://dound.com/2009/04/git-forever-remove-files-or-folders-from-history/" rel="noreferrer">David Underhill's script</a></li>
<li><a href="https://help.github.com/articles/remove-sensitive-data" rel="noreferrer">Github's Howto</a></li>
</ul>

Both of which were recommend by the Darhuuk's answer to <a href="https://stackoverflow.com/questions/5563564/remove-files-from-git-repo-completely">Remove files from git repo completely</a>

However, after trying both of those solutions the <a href="http://stubbisms.wordpress.com/2009...argest-pack-objects-and-trim-your-waist-line/" rel="noreferrer">script to find large files in git</a> still finds the offending binary. However the script from <a href="https://stackoverflow.com/a/223890/20774">this answer</a> no longer finds the commit for the binary. Both of these scripts were suggest by <a href="https://stackoverflow.com/a/10622293/20774">this answer</a>.

The repo is still 44mb after the attempts at removal, which is way too large for the relative small size of the source. Which suggestions the large file script is doing it's job properly. I've tried pushing up to github (I made a fork just in case) and then doing a fresh clone to see if the repo size was decreased, but it is still the same size.

Can someone explain what I am doing wrong or suggest an alternative method?

I should note that I am not just interested in trimming the file from my local repo, I also want to be able to fix the remote repo on Github.