Can't skip .net strong name verification on windows


Staff member
I have tried to skip .net strong name verification on both Win10 & Win7, following
<a href="" rel="nofollow noreferrer">How to disable strong name validation</a> and <a href="">this</a>, type the following comamnds on both x86 and amd64 environment.

vcvarsall.bat amd64
sn /Vr *
vcvarsall.bat x86
sn /Vr *

but still receive the complains:

=== Pre-bind state information ===
LOG: User = US\Hauck
LOG: DisplayName = TestDll, Version=, Culture=neutral, PublicKeyToken=b1cf2005f5cbe0bd (Fully-specified)
LOG: Appbase = file:///D:/myprojects/bin/
LOG: Initial PrivatePath = NULL
Calling assembly : TestDriver, Version=, Culture=neutral, PublicKeyToken=b1cf2005f5cbe0bd.
LOG: This bind starts in default load context.
LOG: No application configuration file found.
LOG: Using machine configuration file from c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\machine.config.
LOG: Post-policy reference: TestDll, Version=, Culture=neutral, PublicKeyToken=b1cf2005f5cbe0bd
LOG: Attempting download of new URL file:///D:/myprojects/bin/TestDll.DLL.
WRN: Comparing the assembly name resulted in the mismatch: PUBLIC KEY TOKEN 
ERR: Failed to complete setup of assembly (hr = 0x80131040). Probing terminated.

After googling a lot I still have no idea how to skip the verification.


<li><a href="" rel="nofollow noreferrer">How to: Enable a 64-Bit Visual C++ Toolset on the Command Line</a> </li>
<li><a href="" rel="nofollow noreferrer">Bypassing strong-name verification for a .Net assembly</a></li>
<li><a href="" rel="nofollow noreferrer">How to: Disable the Strong-Name Bypass Feature</a></li>