Diaspora: Bundler could not find compatible versions for gem "oauth2":

admin

Administrator
Staff member
After installing bundler, cloned diaspora and changed directory into diaspora. When I try bundle install I get this error:

<blockquote>
Bundler could not find compatible versions for gem "oauth2": In
snapshot (Gemfile.lock):
oauth2 (0.4.1)

In Gemfile:
diaspora-client (>= 0) ruby depends on
oauth2 (= 0.5.0) ruby

Running
Code:
bundle update
will rebuild your snapshot from scratch, using
only the gems in your Gemfile, which may resolve the conflict.
</blockquote>

When I bundle update I get this error:

<blockquote>
Bundler could not find compatible versions for gem "oauth2": In
Gemfile:
diaspora-client (>= 0) ruby depends on
oauth2 (= 0.5.0) ruby

Code:
omniauth (= 0.2.6) ruby depends on
  oauth2 (0.4.1)
</blockquote>

Anyone can help me in solving this issue? I follow the guide on <a href="http://macabhaird.wordpress.com/2011/03/11/installing-diaspora-on-ubuntu-server-10-04-part-2/" rel="nofollow">http://macabhaird.wordpress.com/2011/03/11/installing-diaspora-on-ubuntu-server-10-04-part-2/</a> to set up diaspora. I currently using ubuntu 10.04.3