Elgato Game Capture


New member

First off, sorry if this is in the wrong section, also I have contacted Elgato Support, but I wanted to know if anyone can help me fix it. I can't seem to open my Elgato Game Capture on my desktop, I double click on it and nothing happens, it doesn't open at all. No error messages pop-up, or issues happen. I've tried uninstalling and re-installing nothing works, it installs as normal, I just can't open it. I can open Elgato Sound Capture, but not the Elgato Game Capture.

I am using: Windows 10 Pro 64-bit OS - Windows Version: 1607 (latest version of Windows 10)

Does anyone know how to fix this issue?



Staff member
Apparently it is a known issue with Windows 10 upgrades. Some solved it by downgrading back to Windows 8.1, but it is probably no longer possible.

See whether this solution works - the guy tweaked the settings for Elgato Game Capture so it works right with Windows 10 - it's probably the better of the solutions:

There is also a recommendation at Elgato Systems to use the newer software below. I don't quite trust it though. Maybe they're going to charge or something.