example.com:8080/wordpress = my website | example.com = page could not be found

admin

Administrator
Staff member
I am running lampstack with bitnami wordpress on ubuntu at my home.

Code:
my website = "example.com"
my ip address = "12.123.123.123
my home server's ip address = 192.168.0.101

basically when I go to my example.com:8080/wordpress I get my website, when I go to example.com I get a page could not be found.

my domain registrar www & @ A records point to my home server IP.

So I can get to my website by entering either
Code:
example.com:8080/wordpress
or
Code:
12.123.123.123:8080/wordpress

In my router, I set a port range

Code:
Application: HTTP | Start: 80 | End: 8080 | Protocol: Both | IP Address 192.168.0.101 |     Enable [YES]

How can I get
Code:
example.com
to go to
Code:
example.com:8080/wordpress
?

Here is what my httpd-vhosts.conf file looks like in
Code:
/home/lampstack-5.3.16-0/apache2/conf/extra

Code:
NameVirtualHost *:80
NameVirtualHost *:8080
<VirtualHost *:80>
    DocumentRoot /home/admins/lampstack-5.3.16-0/apps/wordpress
    ServerName example.com
    ServerAlias www.example.com
</VirtualHost>
<VirtualHost *:8080>
    DocumentRoot /home/admins/lampstack-5.3.16-0/apps/wordpress
    ServerName example.com
    ServerAlias www.example.com
</VirtualHost>