Mozilla doesn't want to play vimeo

Genesis

Administrator
Totally frustrated tonight with Mozilla Firefox. As unable to get Vimeo to play. Not only am I unable to get Vimeo player to work, but I can't access vimeo.com (when I test it it is "me only - with Mozilla Firefox" others can access it).

https://vimeo.com/

If I click on the link above it comes up with "Secure connection failed".

Then when I Googled the Vimeo problem it looks as though this is a problem that is a Mozilla Firefox problem now for THREE YEARS and Mozilla Firefox has still not solved the problem. Or does Mozilla Firefox have a good reason for not fixing the problem - it's a Vimeo security issue?

Any one else got the same problem? Have you found a fix for it? I found a few fixes, none of which worked. I don't want to use the solution below as that creates a browser security issue which I'd rather not have since I'm working on secure Websites - I can live without Vimeo if it means compromising security. One of the solutions is to make the below FF/about:config false:
security.mixed_content.block_active_content;true
 

jaran

New member
I test with Aurora version 39.0a2 developer edition and its can playing video from vimeo. Are you sure its not coming from your ISP @genesis ?

Sent from my ASUS_T00F using Tapatalk
 

Genesis

Administrator
jaran said:
I test with Aurora version 39.0a2 developer edition and its can playing video from vimeo. Are you sure its not coming from your ISP @genesis ?

Sent from my ASUS_T00F using Tapatalk
You must be right Jaran. Can't believe it as went to check again just now with Safari, and it worked with Safari. Then just for the heck of it tried it again with Mozilla Firefox and it works now. Wonder what brought that all on? Any way, looks as though I'm OK for now. Thanks.
 

Yozora

Moderator
@"Genesis" With me I find sometimes computers just need a restart to get rid of their quirks. Glad it's working now!
 

Genesis

Administrator
Me too Yozora. I was going to do a WordPress online course and am subscribed and working through the lectures now. Vimeo is much better than Youtube. Am glad it's working out. Probably better work through most of the lectures before I turn off my computer again. Although, the irony here is that the problem was both at work and at home. And it now works at both home and work. Could have been a regional blocking.
 

Genesis

Administrator
I'm almost certain it was my ISP (there is only one with Broadband where I am). As the problem was both at home and at work. I also couldn't get the Vimeo Website up.

It got fixed a few days after I first posted this thread. Have been using Vimeo non-stop since then. And am enjoying my course. :p