Not able to Map Workspace in local folder using VS 2017


Staff member
I was trying to map workspace, due to some issue I have canceled the process and deleted the entry from Manage Workspace.
But when I retried the process, I am getting below error

"The workspace [workspaceName];[Owner] already exists on computer [ComputerName]"

I have tried below things to resolve it

1) using VS Command prompt

First display list of workspaces for named computer giving workspace name and owner:

>tf  workspaces /computer:oldComputerName /collection:”http://devsrvr:8080/tfs/DefaultCollection”

To delete:

>tf workspace /delete WorkSpaceName;OwnerName /collection:”http://devsrvr:8080/tfs/DefaultCollection”

But listing command is not showing any workspace. so this option dosen't help me.
I got the help reference form <a href="" rel="nofollow noreferrer">here</a>

2) Tried Repair Local Visual Studio TFS Workspace Mapping by clearing cache data from
%localappdata%\Microsoft\Team Foundation\5.0\Cache
. This option also didn't work for me. I am still getting same error. <a href="">Reference</a>

3) Checked
Control Panel &gt;&gt; User Account &gt;&gt; Mange Password
for deleted the enetries (It is used to work with older VS version). But this also didn't work.

Please let me know if any one know the resolution.