Storm UI Internal Server Error for local cluster

admin

Administrator
Staff member
Code:
Internal Server Error

org.apache.thrift7.transport.TTransportException: java.net.ConnectException: Connection refused
    at org.apache.thrift7.transport.TSocket.open(TSocket.java:183)
    at org.apache.thrift7.transport.TFramedTransport.open(TFramedTransport.java:81)
    at backtype.storm.thrift$nimbus_client_and_conn.invoke(thrift.clj:75)
    at backtype.storm.ui.core$all_topologies_summary.invoke(core.clj:515)
    at backtype.storm.ui.core$fn__8018.invoke(core.clj:851)
    at compojure.core$make_route$fn__6199.invoke(core.clj:93)
    at compojure.core$if_route$fn__6187.invoke(core.clj:39)
    at compojure.core$if_method$fn__6180.invoke(core.clj:24)
    at compojure.core$routing$fn__6205.invoke(core.clj:106)
    at clojure.core$some.invoke(core.clj:2443)
    at compojure.core$routing.doInvoke(core.clj:106)
    at clojure.lang.RestFn.applyTo(RestFn.java:139)
    at clojure.core$apply.invoke(core.clj:619)
    at compojure.core$routes$fn__6209.invoke(core.clj:111)
    at ring.middleware.reload$wrap_reload$fn__6234.invoke(reload.clj:14)
    at backtype.storm.ui.core$catch_errors$fn__8059.invoke(core.clj:909)
    at ring.middleware.keyword_params$wrap_keyword_params$fn__6876.invoke(keyword_params.clj:27)
    at ring.middleware.nested_params$wrap_nested_params$fn__6915.invoke(nested_params.clj:65)
    at ring.middleware.params$wrap_params$fn__6848.invoke(params.clj:55)
    at ring.middleware.multipart_params$wrap_multipart_params$fn__6943.invoke(multipart_params.clj:103)
    at ring.middleware.flash$wrap_flash$fn__7124.invoke(flash.clj:14)

I follow the method in <a href="https://hadooptips.wordpress.com/2014/05/26/configuring-single-node-storm-cluster/" rel="nofollow">https://hadooptips.wordpress.com/2014/05/26/configuring-single-node-storm-cluster/</a> to set up my storm in Ubuntu 14.04 LTS.
When I try to connect to the Storm UI, the error as shown above.
My storm.yaml in /home/user/storm/conf is as below:

Code:
########### These MUST be filled in for a storm configuration
 storm.zookeeper.servers:
     - "localhost"

 storm.zookeeper.port: 2181

 nimbus.host: "localhost"
 nimbus.thrift.port: 6627
# ui.port:8772

 storm.local.dir: "/home/user/storm/data"

 java.library.path: "/usr/lib/jvm/java-7-oracle"

 supervisor.slots.ports:
     - 6700
     - 6701
     - 6702
     - 6703
     - 6704

Anyone know how to solve this? I'm a newbie, a detail solution will be helpful.

My zoo.cfg is as below:

Code:
# The number of milliseconds of each tick
tickTime=2000 

# The number of ticks that the initial synchronization phase can take
initLimit=10  

# The number of ticks that can pass between sending a request and getting an acknowledgement
syncLimit=5  

# the directory where the snapshot is stored.
dataDir=/home/user/zookeeper-data  

# The location of the log file
 dataLogDir=/home/user/zookeeper/log/data_log 

# the port at which the clients will connect
clientPort=2181  
server.1=10.0.0.2:2888:3888  
server.2=10.0.0.3:2888:3888  
server.3=10.0.0.4:2888:3888  

# The number of snapshots to retain in dataDir
autopurge.snapRetainCount=3

# Purge task interval in hours
# Set to "0" to disable auto purge feature
autopurge.purgeInterval=1

I run this in VMWare, Ubuntu 14.04 LTS. What IP address should I put in the server.1 ?