Stylesheets not loading on Woocommerce archive and single product pages leaving them unformatted


Staff member
I've encountered an interesting problem on one of my client's Woocommerce archive and single product pages.

For some reason, no stylesheet is loading at all on these pages and they are completely unformatted. Oddly enough, the stylesheets seem to be loading on the cart and checkout page just fine. This is a pretty basic store, all I really need is the default Woocommerce stylesheets to load for now.

<a href="" rel="nofollow noreferrer"></a>

Single Product Example:
<a href="" rel="nofollow noreferrer"></a>

From my research, I came across two possible answers online and implemented them both with no luck yet.

The first possible fix I came across suggested putting
&lt;?php body_class(); ?&gt;
inside the
tag like this in header.php:

&lt;body &lt;?php body_class(); ?&gt;&gt;

I can confirm that this is done.

The second solution involves editing the woocommerce.php file by wrapping the

&lt;?php woocommerce_content(); ?&gt;
in a
&lt;div class="woocommerce"&gt;&lt;/div&gt;

Unfortunately, the people in the articles didn't share the exact syntax they used so I tried a couple different ways of "wrapping". Here is what I tried. (I'm new to wordpress development so don't laugh too hard):

&lt;div class="woocommerce"&gt;&lt;?php woocommerce_content(); ?&gt;&lt;/div&gt;

&lt;div class="woocommerce" &lt;?php woocommerce_content(); ?&gt;&gt;&lt;/div&gt;

&lt;div class="woocommerce"&gt;&lt;?php woocommerce_content(); ?&gt; PAGE CONTENT &lt;/div&gt;

1) Am I doing this right?

2) If so, what else could cause the stylesheets not to load?

I will post the articles referencing solutions in the comments because I have reached my link limit.

Thanks in advance for anyone who puts time into helping me with a solution. I deeply appreciate your time and effort and will find a way to pay it forward somehow.