subversion "out-of-date" question

admin

Administrator
Staff member
I'm using subversion so that I can have two checkouts, one for testing to make sure things work and another which is public live site. I made some changes in the test site but also made some updates to a wordpress install. Now I can't commit the changes on my live site.

Code:
[[email protected] public_html]$ svn commit -m "this time, it's personal"
svn: Commit failed (details follow):
svn: Working copy
'/usr/local/apache/sites/nextadvisor_admin/blog/wp-content/plugins' is
missing or not locked

so I...

Code:
[[email protected] public_html]$svn rm blog/wp-content/plugins --force
[[email protected] public_html]$svn rm blog/wp-content/plugins --force
[[email protected] public_html]$svn add blog/wp-content/plugins --force

and all the files got re-added, then I

Code:
[[email protected] public_html]$ svn commit -m "this time really"
Sending        blog/.htaccess
Replacing      blog/wp-content
svn: Commit failed (details follow):
svn: Out of date: '/trunk/blog/wp-content/plugins' in transaction '186-1'

Okay so when I look online it tells me to do svn update but I tried that once before and it just erases all my local changes because the "blog/" folder doesn't exist in my test checkout.

My question is, how can I make this commit work without losing the local edits?

Update:

When I run svnupdate, it tells me:

svn: Working copy path 'blog/wp-content/plugins' does not exist in repository