The htaccess file in my root is redirecting my wordpress site in my /apply/ directory to my root index. Help! :\


Staff member
My domain is <a href="" rel="nofollow"></a>. I installed some new software onto my site and it required that I enable mod_rewrite. It was already enabled on the server but I was told I had to also include it in my htaccess file. I also needed to install the software in the root of my site, where my wordpress blog originally was. So I moved my Wordpress blog to a new directory, and named it /apply. It was working fine, until I enabled mod_rewrite by adding this to the root htaccess file:

DirectoryIndex router.php
Options +FollowSymLinks
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond $1 ^(.*)$
RewriteRule ^(.*)$ router.php?_doroute=$1 [L,QSA]

Now, going to my Wordpress directory redirects to my root page. Please help :\

Also, <strong>going to <a href="" rel="nofollow"></a> and other pages all works.</strong>

This is the htaccess file info from my Wordpress directory (/apply):

# BEGIN WordPress
&lt;IfModule mod_rewrite.c&gt;
RewriteEngine On
RewriteBase /apply/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /apply/index.php [L]

# END WordPress