Wordpress widgets not displaying on custom theme

admin

Administrator
Staff member
I built a custom wordpress theme, and I also built a custom widget sidebar (so widgets are enabled), I can see the title of the widget, but the content is not showing. For example I'm using a poll widget, the title is exactly as I've set it, but the content is completely blank.

In the header the scripts for the plugin are loaded, but again there is no content. I tried multiple plugins, and they all do the same thing. I also attempted this with using do_shortcode() and again, no content. So I am stumped.

I have also tried getting support on the wordpress forum, but I've never successfully gotten an answer to my query there.

My hope is that someone has had this same issue, and can point me to what the problem may be.

In the header, i've included the following information:

Code:
<html <?php language_attributes(); ?>>
<meta charset="<?php bloginfo( 'charset' ); ?>" />
<?php wp_head();?>
<?php wp_meta();?>
<?php wp_print_scripts();?>

However again, no results. Google searches have also not pulled up anything about this being an issue. Here's the odd thing, I design all wordpress themes the same way, most of which are all hosted on the same server, and this is the only theme having this problem.

Also I've included my functions.php script for reference purposes.

Code:
<?php
function twentyten_widgets_init() {

    register_sidebar( array(
        'name' => __( 'Primary Widget Area', 'twentyten' ),
        'id' => 'primary-widget-area',
        'description' => __( 'Add widgets here to appear in your sidebar.', 'twentyten' ),
        'before_widget' => '<div id="spacer">',
        'after_widget' => '</div></div>',
        'before_title' => '<div id="left_top">',
        'after_title' => '</div><div id="left_bottom">',
    ) );
}

add_action( 'widgets_init', 'twentyten_widgets_init' );

add_filter( 'show_admin_bar', '__return_false' );

remove_action( 'personal_options', '_admin_bar_preferences' );
?>

<em><strong></em> EDIT **</strong>
I removed from the header as it was causing duplicate scripts in the header. So that is no longer an issue, however that did not resolve the issue and nothing has changed as a result of being removed.